Reading UK - Routing Problems
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Mar 17, 2017 - 11:25 UTC
Monitoring
We have resolved the issue and are continuing to monitor.
Posted Mar 17, 2017 - 11:04 UTC
Investigating
We are currently investigating this issue.
Posted Mar 17, 2017 - 10:14 UTC