Service Outage Thursday May 18, 2017 12:00pm - 12:30pm US Eastern
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted May 18, 2017 - 18:22 UTC
Monitoring
Services are now functioning properly. We will continue to monitor for the next couple hours.
Posted May 18, 2017 - 16:50 UTC
Identified
We have identified a network routing issue and we have begun remediation. Services should now be accessible but may be slow. We will continue to provide updates until this problem is fully resolved.
Posted May 18, 2017 - 16:32 UTC
Investigating
Customers are unable to access login.barracuda.com. Barracuda first started seeing this outage at 12:00pm US Eastern. Barracuda Engineering is aware and is working to restore full functionality for all customers.

Affected services:
Web UI management for all services
Posted May 18, 2017 - 16:13 UTC
This incident affected: Cloud Archiving Service (Web Interface), Web Security Service (Management Web UI, Traffic Processing), Backup Service (Web Interface, Email Alerts / Reports, Offsite Transfers), Corporate Website (Campus, Blog, www, Community), CloudGen Firewall (Advanced Threat Protection), and BarracudaCentral.org, Cloud Control.