Barracuda Backup Web UI Degraded beginning May 15, 2017 15:00 US Eastern
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted May 16, 2017 - 00:56 UTC
Monitoring
All customer services are now recovering.
Posted May 15, 2017 - 23:20 UTC
Update
Barracuda Engineering is pushing a fix to resolve this problem. Will provide another update within the next 30 minutes.
Posted May 15, 2017 - 23:00 UTC
Identified
Web services for several Barracuda products are affected. We have identified the problem and are working on remediation effort right now. Will provide an update within the next 30 mins.
This issue should only be affecting web management. Services should be otherwise functioning as intended.

Affected Services:
Barracuda Backup
Cloud Archiving Service
Email Security Service (Admin only)
Web Security Service
Posted May 15, 2017 - 22:41 UTC
Investigating
Barracuda Backup customers may be experiencing intermittent connectivity or slow response times for the Barracuda Backup Web UI. Barracuda first started seeing this degraded service at 15:00 US Eastern. Barracuda Engineering is aware and is working to restore full functionality for all customers.

Affected services:
Barracuda Backup
Posted May 15, 2017 - 20:08 UTC
This incident affected: Cloud Archiving Service (Web Interface), Web Security Service (Management Web UI), and Backup Service (Web Interface).