Barracuda Cloud Control Service Degraded
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Apr 21, 2017 - 18:21 UTC
Investigating
Customers may be experiencing slow response times while using Barracuda Cloud Control. Barracuda Engineering is aware and is working to remedy the situation.

Affected services:
- Barracuda Cloud Control
Posted Apr 21, 2017 - 15:59 UTC