Cloud to Cloud Backup Issue Affecting Customers in the US Region
Incident Report for Barracuda Networks
Resolved
The issue had been resolved.
Posted 30 days ago. Oct 18, 2018 - 09:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Oct 17, 2018 - 16:39 UTC
Identified
We have identified an issue that is affecting Cloud-to-Cloud Backup customers in the US Region. Backup and restore functionality may be affected by this issue.
Posted about 1 month ago. Oct 17, 2018 - 13:18 UTC
This incident affected: Cloud to Cloud Backup (Office 365 Integration).