Cloud to Cloud Backup Issue Affecting Customers in the US Region
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jul 18, 2018 - 10:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2018 - 15:07 UTC
Investigating
We are investigating an issue that is affecting Cloud-to-Cloud Backup customers in the US Region. Backup and restore functionality may be affected by this issue.
Posted Jul 16, 2018 - 12:33 UTC
This incident affected: Cloud to Cloud Backup (Office 365 Integration).