Barracuda Appliance Control Cloud Backups
Incident Report for Barracuda Networks
Resolved
We have confirmed that service has been fully restored. Please contact support if you experience any further issues.
Posted Mar 08, 2019 - 00:11 UTC
Monitoring
We have fixed the issue and are monitoring the Appliance Control Cloud Backup service closely.
Posted Mar 07, 2019 - 18:51 UTC
Investigating
We are investigating reports of cloud backups for Barracuda appliances not completing properly.
Posted Mar 07, 2019 - 17:47 UTC
This incident affected: Appliance Control (Cloud backups).