Barracuda Appliance Control - Degraded Performance
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jul 19, 2018 - 12:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 19, 2018 - 12:31 UTC
Investigating
Customers in may be experiencing problems with the the tree loading. Barracuda Engineering is aware and is working to restore full functionality for all customers.
Posted Jul 19, 2018 - 12:25 UTC
This incident affected: Appliance Control (Web Interface).