Barracuda Cloud-to-Cloud Backup (CCB) Degraded Performance in U.S. Region
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted May 23, 2022 - 10:59 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 20, 2022 - 20:39 UTC
Update
We are continuing to work on a fix for this issue. Customers may see issues with backup, restore, and export jobs not running as expected.
Posted May 19, 2022 - 14:28 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 18, 2022 - 21:44 UTC
Investigating
We are currently investigating an issue impacting Barracuda Cloud-to-Cloud Backup (CCB) customers in the U.S. region. Customers may see duplicate backup jobs and stale backup reports.
Posted May 18, 2022 - 21:43 UTC
This incident affected: Cloud to Cloud Backup (Web Interface, Cloud to Cloud Backups).