ESS DE is having issue - 451 Server too busy
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 17:23 UTC
Monitoring
We have resolved the issue causing the delays in mailflow. Deferrals have been resolved, and we continue to monitor to ensure the issue does not recur.
Posted Oct 15, 2020 - 16:16 UTC
Update
Our engineering team has identified the issue and has begun efforts to solve the issue. We will notify you as soon as the solution has been put in place.

We will provide another update as soon as the solution is in place.
Posted Oct 15, 2020 - 16:13 UTC
Update
We've identified the root cause and have addressed the issue causing deferrals. Mail will be delayed as sending servers retry.
Posted Oct 15, 2020 - 14:54 UTC
Investigating
ESS is currently experiencing an issue. Our engineers are currently working to identify the cause and get our services back online. We understand this has impacts on your business, we are working to get you up and running as fast as possible.

We will provide another update once the issue has been identified and we have started to implement a solution.
Posted Oct 15, 2020 - 11:39 UTC
This incident affected: Email Gateway Defense (Mail Delivery, User Interface).