CCB and BBS - UK Region: Degraded networking performance
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Mar 01, 2019 - 14:10 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2019 - 14:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 22, 2019 - 19:08 UTC
Investigating
The CCB and BBS services in UK Region are experiencing degraded networking performance due to congestion between Barracuda and our upstream providers.
Posted Feb 22, 2019 - 14:23 UTC
This incident affected: Cloud to Cloud Backup (Office 365 Integration) and Backup Service (Offsite Transfers).