Email Gateway Defense - Slow or unsuccessful message log UI loading

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 16:31 UTC

Monitoring

The Email Gateway Defense web interface issue has stabilized, and UI performance is back to normal. We are continuing to monitor.
Posted Oct 30, 2025 - 04:11 UTC

Investigating

We are investigating an issue that is affecting the Email Gateway Defense web interface. User interface performance may be affected by this issue.
Posted Oct 29, 2025 - 16:23 UTC
This incident affected: Email Gateway Defense (User Interface).