Data Inspector - Degraded Performance

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 13:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 29, 2025 - 20:33 UTC

Investigating

We are investigating reports of slow or unsuccessful Data Inspector web interface loading, which is related to an issue with our upstream provider.
Posted Oct 29, 2025 - 17:03 UTC
This incident affected: Data Inspector.