Email Gateway Defense incorrectly blocking email from certain domains
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jan 24, 2023 - 22:32 UTC
Monitoring
A fix has been implemented and we are monitoring the status. The emails that were previously blocked will need to be re-delivered manually or the sender can retry when an NDR is received.
Posted Jan 24, 2023 - 19:28 UTC
Investigating
Email Gateway Defense is incorrectly blocking email from certain domains. Only a small percentage of emails are impacted at this time. We are working actively to fix this issue. We are sorry for any inconvenience. We will keep you updated on progress.
Posted Jan 24, 2023 - 16:49 UTC
This incident affected: Email Gateway Defense (Mail Delivery).