Email Security Service - Degraded Message Log
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jan 18, 2018 - 00:14 UTC
Monitoring
Barracuda has resolved the message log issue and will continue to monitor.
Posted Jan 17, 2018 - 19:52 UTC
Update
This is only impacting some US customers.
Posted Jan 17, 2018 - 19:35 UTC
Investigating
Some customers may be experiencing issues when viewing the message log. Barracuda is aware of the issue and working on a solution. Mailflow is unaffected at this time.
Posted Jan 17, 2018 - 19:31 UTC