Imports from uploaded PST files are delayed - EU Region
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jun 04, 2021 - 19:38 UTC
Update
Our engineering team has identified the issue and is working on a resolution. PST imports and exports are processing, and we expect all delayed tasks to complete by June 4, 2021.
Posted May 28, 2021 - 21:11 UTC
Update
Our engineering team has identified the issue and is working on a resolution. PST imports and exports are now processing, and we will provide an ETA for completion of all tasks by the end of the day on May 28, 2021.
Posted May 26, 2021 - 23:34 UTC
Identified
Our engineering team has identified the issue and has begun efforts to resolve the issue. We will notify you as soon as the solution has been put in place.

We will provide another update as soon as the solution is in place.
Posted May 14, 2021 - 15:06 UTC
This incident affected: Cloud Archiving Service (PST Import).