Email Security Service website issues in the UK region
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Aug 09, 2018 - 23:37 UTC
Monitoring
We have identified the issue and implemented a fix.
Posted Aug 09, 2018 - 22:57 UTC
Investigating
We are investigating issues reaching the website for Email Security Service in the UK region
Posted Aug 09, 2018 - 22:14 UTC
This incident affected: Email Gateway Defense (User Interface).