ESS UK - outbound mail delivery issues
Incident Report for Barracuda Networks
Resolved
We have confirmed that service has been fully restored. Please contact support if you experience any further issues.
Posted Dec 05, 2018 - 00:03 UTC
Monitoring
A fix has been implemented and we are monitoring service health.
Posted Dec 04, 2018 - 23:12 UTC
Investigating
Beginning on 12/4/2018 @ 14:29 PST, Barracuda noticed issues with ESS Outbound SMTP Delivery in our Email Security Service for Essentials. We are actively investigating and working towards a resolution.

We apologize for any inconvenience this may be causing.
Posted Dec 04, 2018 - 22:55 UTC
This incident affected: Email Gateway Defense (Mail Delivery).