Barracuda Cloud Archiving Service - US region Outage beginning 1/12/2017 11:00 UTC
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jan 12, 2018 - 12:01 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 12, 2018 - 11:34 UTC
Identified
Customers in the US are unable to access the Barracuda Cloud Archiving Service. Barracuda first started seeing this outage at 1/12/2017 11:00 UTC. Barracuda Engineering is aware and is working to restore full functionality for all customers.

Affected services:
Barracuda Cloud Archiving Service - US Region (mas.barracudanetworks.com)
Posted Jan 12, 2018 - 11:26 UTC
This incident affected: Cloud Archiving Service (Web Interface, End-user Access, Mail Processing, Exchange Integration, PST Import) and Cloud Control.