Cloud to Cloud and Barracuda Backup Issue Affecting Customers
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Apr 24, 2019 - 17:16 UTC
Investigating
We are investigating an issue that is affecting Cloud-to-Cloud and Backup customers. Web app responsiveness, and Backup and Restore functionality may be experiencing some slowdowns due to this issue.
Posted Apr 24, 2019 - 09:28 UTC
This incident affected: Backup Service (Web Interface) and Cloud to Cloud Backup (Web Interface, Office 365 Integration).