Barracuda Cloud Archiving Service - Reading, UK - Bandwidth Issues
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Sep 16, 2020 - 17:05 UTC
Identified
Engineering has identified an issue with the UK datacenter that is causing the Outlook Add-in and BCAS web UI to be sluggish, particularly during the morning. We have identified bandwidth issues as the cause of this. We wish to apologize for any inconvenience this is causing.

There is no need to contact support with this issue if you are experiencing it. Barracuda is aware of the situation and is handling it as a top priority. There is no chance for data loss. Additional bandwidth measures are currently being put into place to alleviate this issue.

Thank you for being a Barracuda Networks customer. We will update this page with new information as it becomes available.
Posted Aug 07, 2020 - 15:12 UTC
This incident affected: Cloud Archiving Service (Web Interface).