ESS Mailflow Issues in the UK Region
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Oct 13, 2017 - 21:01 UTC
Investigating
We are experiencing inbound mailflow issues in our UK region
Posted Oct 13, 2017 - 20:23 UTC