ESS Web UI degraded performance in the US Region
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jan 15, 2019 - 23:06 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2019 - 23:33 UTC
Investigating
Beginning on 2019-01-14 @ 5:19AM PST, Barracuda noticed WebUI issues in our Email Security Service for Essentials. We are actively investigating and working towards a resolution.

No other components of the email security services are affected. We apologize for any inconvenience this may be causing.
Posted Jan 14, 2019 - 15:43 UTC
This incident affected: Email Gateway Defense (User Interface).