Barracuda Cloud Archiving Service – United States Region – Slow and Inconsistent Services
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Oct 30, 2020 - 15:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 28, 2020 - 19:55 UTC
Identified
Barracuda Engineering has identified an issue with our United States datacenter. The issue is causing slowness and interruptions in some services. Barracuda was made aware of this issue on October 21, 2020. The services affected are web access, inbound SMTP traffic, and SFTP download services. The impact of this issue is slow or dropped web connections, deferred SMTP traffic going to the Archiving service, and slow or dropped SFTP connections. We wish to apologize for any inconvenience this is causing.
There is no need to contact support if you are experiencing this issue. Barracuda is aware of the situation and is handling it with top priority. There is no chance for data loss. Remediations are ongoing in the interim until a permanent fix is established, and services should become more stable soon.
Thank you for being a Barracuda Networks customer. We will update this page with new information as it becomes available.
Posted Oct 26, 2020 - 19:45 UTC
This incident affected: Cloud Archiving Service (Web Interface, Mail Processing).