Network Connectivity to Australia Region for Barracuda Backup
Incident Report for Barracuda Networks
Resolved
The Backup service in the Australia region has been fully restored.
Posted Mar 15, 2018 - 15:15 UTC
Investigating
We are experiencing a network connectivity problem in the Australia region for Barracuda Backup service.
Posted Mar 15, 2018 - 14:22 UTC
This incident affected: Backup Service (Web Interface, Email Alerts / Reports, Offsite Transfers).