Delayed Outbound Mail Delivery in US Region
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jan 18, 2019 - 17:34 UTC
Investigating
Beginning on 1/18/2019 @ 7:30AM PST, Barracuda noticed issues with Outbound Mail Delivery in our Email Security Service for Essentials. We are actively investigating and working towards a resolution.

No other components of the email security services are noted at this time. We apologize for any inconvenience this may be causing.
Posted Jan 18, 2019 - 16:19 UTC
This incident affected: Email Gateway Defense (Mail Delivery).