Access issues with community.barracudanetworks.com
Incident Report for Barracuda Networks
Resolved
The issue has been resolved!
Posted Dec 04, 2018 - 17:51 UTC
Identified
We are observing access issues with community.barracudanetworks.com. We are currently working to remediate the issue
Posted Dec 04, 2018 - 16:21 UTC
This incident affected: Corporate Website (Community).