Email Encryption service - US region
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted 4 months ago. May 01, 2019 - 23:37 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 4 months ago. May 01, 2019 - 21:47 UTC
Identified
Customers using the Email Encryption service in the US region may be experiencing issues with the service. We are working on fixing the issue at this time.
Posted 4 months ago. May 01, 2019 - 21:18 UTC
This incident affected: Email Security Service (Mail Delivery).