Cloud to Cloud Backup Issue Affecting Customers in the US Region
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jan 21, 2019 - 14:54 UTC
Monitoring
A fix has been implemented and we are monitoring the status. Delayed backup jobs may take some time to fully catch up.
Posted Jan 17, 2019 - 14:04 UTC
Identified
Some Cloud to Cloud Backup customers in the US region are experiencing delayed or failed backups. We are working on resolving this issue.
Posted Jan 16, 2019 - 19:49 UTC
This incident affected: Cloud to Cloud Backup (Office 365 Integration).