Cloud to Cloud Backup Issue Affecting Customers in the US Region
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Mar 17, 2018 - 12:13 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 17, 2018 - 11:53 UTC
Investigating
We are investigating an issue that is affecting Cloud-to-Cloud Backup customers in the US Region. Backup and restore functionality may be affected by this issue.
Posted Mar 17, 2018 - 11:25 UTC
This incident affected: Cloud to Cloud Backup (Office 365 Integration).