ESS Web UI failing to load
Incident Report for Barracuda Networks
Resolved
We have confirmed that service has been fully restored. Please contact support if you experience any further issues.
Posted Mar 14, 2019 - 18:32 UTC
Monitoring
We have fixed the issue and are monitoring the email security service closely.
Posted Mar 14, 2019 - 17:32 UTC
This incident affected: Email Gateway Defense (User Interface).