Cloud Archiving Service - Degraded Performance

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 12:45 UTC

Monitoring

Services appear to have recovered. We are continuing to monitor.
Posted Oct 29, 2025 - 19:31 UTC

Investigating

We are investigating reports of slow or unsuccessful Cloud Archiving Service web interface loading, which is related to an issue with our upstream provider.
Posted Oct 29, 2025 - 17:58 UTC
This incident affected: Cloud Archiving Service (Web Interface).