Barracuda Email Security Delivery Delays for some Email Providers
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Feb 25, 2019 - 18:53 UTC
Identified
Barracuda is aware that a number of IPs that were recently brought online to service our customers in the US region are being blacklisted by some email service providers. We are working with the email service providers to delist our new IP addresses.
Posted Feb 18, 2019 - 16:08 UTC
This incident affected: Email Gateway Defense (Mail Delivery).