Email deletion delays
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Oct 23, 2020 - 20:36 UTC
Monitoring
We have identified and addressed an issue in Forensics and Incident Response that caused delays in incident creation and email deletion. Email deletion delays are still present, but should resolve shortly.
Posted Oct 23, 2020 - 20:03 UTC
This incident affected: Incident Response (Email Processing).