Network Connectivity to Canada Region for Barracuda Backup
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Mar 18, 2018 - 01:00 UTC
Investigating
We are experiencing problems with connectivity to our Canada region for the Barracuda Backup product.
Posted Mar 17, 2018 - 20:35 UTC
This incident affected: Backup Service (Offsite Transfers).