Barracuda Cloud Archiving Service
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jul 15, 2017 - 00:39 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 15, 2017 - 00:29 UTC
Investigating
We are currently investigating reports of intermittent latency when trying to access the Barracuda Cloud Archiving Service through Barracuda Cloud Control.
Posted Jul 14, 2017 - 23:32 UTC
This incident affected: Cloud Archiving Service (Web Interface, End-user Access).