Barracuda Backup (BBS) - Cloud Interface Loading Slowly or Not At All
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Apr 22, 2021 - 14:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 22, 2021 - 13:12 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 22, 2021 - 13:11 UTC
Investigating
The Barracuda Backup cloud interface is loading slowly or not at all for some customers. We are currently investigating this issue and will provide updates when more information is available.
Posted Apr 22, 2021 - 13:10 UTC
This incident affected: Backup Service (Web Interface).