Mail Archiving Delays in EMEA Central Region
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Apr 10, 2020 - 15:33 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2020 - 13:16 UTC
Identified
At approximately 5:30PM UTC, Barracuda Networks was made aware of an incident regarding email sent from customer email servers to the Barracuda Cloud Archiving Service hosted in Frankfurt, Germany. Mail sent to this datacenter was being deferred back to customer email servers. Approximately 600 customers were affected by this outage. If you are using the Cloud Archiving Service and in non-UK regions of Europe, the Middle East, and Asia, you may notice mail queueing on your mail server as deferred.

Barracuda has identified the issue causing this problem. No email data loss has occured.
Posted Mar 17, 2020 - 19:48 UTC
This incident affected: Message Archiver (Cloud Replication) and Cloud Archiving Service (Mail Processing).