Barracuda Backup - Cloud UI Performance Issues
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Jul 23, 2021 - 18:30 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2021 - 14:41 UTC
Investigating
We are currently investigating an issue causing the Barracuda Backup cloud interface to load slowly or not at all for some customers.
Posted Jul 23, 2021 - 13:16 UTC
This incident affected: Backup Service (Web Interface).