Barracuda Email Security Service recovering
Incident Report for Barracuda Networks
Resolved
Service is now functioning properly.
Posted Nov 03, 2016 - 18:08 UTC
Update
Barracuda Networks is still continuing to see a large number of inbound connections from unverified sources for customers using Essentials for Email Security and Cloud Protection Layer. We have successfully filtered and are actively monitoring the situation while taking the appropriate actions when needed. Email processing has returned to normal. Previously delayed emails are now being accepted and processed. We are continuing our investigation and will notify our customers once an analysis has been completed. Thank you for your patience.
Posted Nov 03, 2016 - 00:44 UTC
Monitoring
Since 7PM PDT 11/1/2016, the Barracuda Essentials for Email Security service has been experiencing a sustained and unusually large number of inbound connections from unverified sources. This resulted in some customers experiencing delays in email delivery and issues accessing the message/quarantine logs. We have made significant progress sanitizing these connections. At this point, email processing capabilities have returned to normal and backlogged messages are being delivered. Also, access to the message and quarantine logs is fully restored. We are continuously monitoring the connection load, taking further steps to mitigate the impact and tracing the root cause. Our priority is to restore the service to full capacity. We will provide more information through the course of the investigation. Thank you for your patience.
Posted Nov 02, 2016 - 22:39 UTC
Update
Since 7PM PDT 11/1/2016, the Barracuda Essentials for Email Security service has been experiencing a sustained and unusually large number of inbound connections from unverified sources. This resulted in some customers experiencing delays in email delivery and issues accessing the message/quarantine logs. We have made significant progress sanitizing these connections. At this point, email processing capabilities have returned to normal and backlogged messages are being delivered. Also, access to the message and quarantine logs is fully restored. We are continuously monitoring the connection load, taking further steps to mitigate the impact and tracing the root cause. Our priority is to restore the service to full capacity. We will provide more information through the course of the investigation. Thank you for your patience.
Posted Nov 02, 2016 - 22:39 UTC
Identified
Some customers using the Barracuda Essentials for Email Security solution are experiencing delays in incoming email delivery, accessing the message log and end user quarantine interfaces. Other parts of the administrative user interface are fully accessible. We are actively working on the problem. Our initial investigations revealed an unusually high volume of inbound connections from multiple unverified source IPs. We are in the process of sanitizing this traffic. As a result, the quality of service is gradually improving.

Our first priority is to restore the services to full capacity. We will provide more information as it becomes available. Thank you for your patience.
Posted Nov 02, 2016 - 19:29 UTC
Update
Engineering and Operations teams are still working to resolve delays in mail delivery.
Posted Nov 02, 2016 - 15:18 UTC
Investigating
Customers are experiencing delays with inbound message delivery. Outbound is unaffected.

Barracuda Engineering and Operations teams are investigating.
Posted Nov 02, 2016 - 13:39 UTC