Scheduled Retention - US Region
Incident Report for Barracuda Networks
Resolved
As of Saturday, November 20th all scheduled retentions have been reenabled. Please contact support if you experience any further issues.
Posted Nov 30, 2021 - 23:51 UTC
Identified
Barracuda Cloud Archiving Service is experiencing an issue with retention being scheduled in the US region. Our engineers are currently investigating the issue.

In the meantime, customers who require immediate retention scheduling should contact support, who can process it manually on your behalf.

We will provide another update once we have started to implement a solution.
Posted Aug 27, 2021 - 17:10 UTC
This incident affected: Cloud Archiving Service (Retention).