Barracuda Cloud-to-Cloud Backup Service Degradation (Global)

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Jul 01, 2025 - 12:58 UTC

Monitoring

A fix has been released to address redirect issues in the Cloud-to-Cloud Backup UI. We are monitoring the results.
Posted Jun 26, 2025 - 14:48 UTC

Identified

A fix was implemented yesterday to address the primary issue leading customers to the initial setup screen. We are still seeing some redirect issues and are awaiting a fix to address them.
Posted Jun 25, 2025 - 12:33 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2025 - 22:39 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 24, 2025 - 14:22 UTC

Investigating

We are currently investigating an issue impacting the ability to get to the Cloud-to-Cloud Backup interface. Customers are being presented with the initial setup screen (region selection).
Posted Jun 24, 2025 - 11:31 UTC
This incident affected: Cloud to Cloud Backup (Web Interface).