Barracuda Cloud-to-Cloud Backup (CCB) Degraded Performance in U.S. Region
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted May 18, 2022 - 12:52 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 17, 2022 - 20:13 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 17, 2022 - 17:55 UTC
Investigating
We are currently investigating an issue impacting Barracuda Cloud-to-Cloud Backup (CCB) customers in the U.S. region. All services related to configuration, reporting, backup, and restoration are impacted.
Posted May 17, 2022 - 17:48 UTC
This incident affected: Cloud to Cloud Backup (Web Interface, Office 365 Integration, Cloud to Cloud Backups).