View - Service Degradation

Incident Report for Barracuda Networks

Resolved

The issue with AWS has resolved and the delayed SMTP has been processed.
Posted Oct 21, 2025 - 13:23 UTC

Identified

View is currently experiencing an issue resulting from an AWS outage that is impacting SMTP. Our engineers are currently working to identify the cause and get our services back online. We understand this has an impact on your business, and we are working to get you up and running as quickly as possible.
Posted Oct 20, 2025 - 19:31 UTC

Investigating

View is currently experiencing an issue resulting from an AWS outage that is impacting SMTP. Our engineers are currently working to identify the cause and get our services back online. We understand this has an impact on your business, and we are working to get you up and running as quickly as possible.

We will provide another update once the issue has been identified and we have started to implement a solution. (edited)
Posted Oct 20, 2025 - 15:06 UTC
This incident affected: View - Cloud Email Archive (US | nest1-view-us | viewarchive.com, US | im1-view-us |, US | rack1-view-us |).