incident-ess-113
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Feb 22, 2021 - 13:15 UTC
Monitoring
We have solved the issue and are monitoring to ensure the issue does not come back. If you have any additional issues, please reach out to the support team.
Posted Feb 22, 2021 - 12:46 UTC
Identified
Our engineering team has identified the issue and has begun efforts to solve the issue. We will notify you as soon as the solution has been put in place. We will provide another update as soon as the solution is in place.
Posted Feb 22, 2021 - 10:47 UTC
Investigating
ESS is currently experiencing an issue on Inbound connection. Our engineers are currently working to identify the cause and get our services back online. We understand this has impacts on your business, we are working to get you up and running as fast as possible.
Posted Feb 22, 2021 - 10:30 UTC
This incident affected: Email Gateway Defense (Mail Delivery).