Incident Response - Slow email ingestion is limiting search and resulting in error in searching for messages

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 17:57 UTC

Monitoring

We're currently experiencing ingestion delays with incident response. A fix has been identified and we're currently monitoring.
Posted Mar 27, 2026 - 13:18 UTC
This incident affected: Incident Response (Email Processing).