Mail processing degraded in US region

Incident Report for Barracuda Networks

Resolved

This issue has been resolved for all customers and mail processing has been restored to full capacity. All items are now available for search results.
Posted May 01, 2026 - 20:03 UTC

Monitoring

Mail processing service has been restored for nearly all customers with a very small set of affected items remaining. We are continuing to work towards resolution for those remaining items.
Posted May 01, 2026 - 15:25 UTC

Identified

Mail processing service is currently degraded for some customers in the US region. Engineering has identified the issue and is working to restore full capacity to the service. Message ingestion is unaffected, but new items and some search results may be unavailable until service is restored.
Posted Apr 30, 2026 - 07:54 UTC
This incident affected: Cloud Archiving Service (Mail Processing).