Microsoft service outage
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 12:34 UTC
Monitoring
Due to a Microsoft service outage, backup and restore operations in the following regions: US, Canada and Sydney may have been aborted. Jobs will run on schedule upon resolution of the Microsoft service outage.
Posted Sep 29, 2020 - 00:43 UTC
This incident affected: Cloud to Cloud Backup (Office 365 Integration).