XDR Service Interruption

Incident Report for Barracuda Networks

Resolved

Our engineering team has implemented a solution to resolve this issue. Thanks for your patience!
Posted Mar 24, 2025 - 16:17 UTC

Monitoring

Our engineering team has identified the cause of this issue and implemented a solution. We will continue to monitor to ensure the impacted service is fully operational.
Posted Mar 22, 2025 - 02:48 UTC

Identified

Barracuda XDR is currently experiencing an issue in the data ingestion process which results in the delayed events ingestion on some of integration datasources into our platform. Our engineers have identified the cause and are currently working on resolving this service issue. We understand the impact this may have on your business and are committed to restoring this service to fully operational as quickly as possible.

The core XDR service (signal detection) is not impacted. We will provide further updates as we implement a solution.
Posted Mar 21, 2025 - 19:41 UTC
This incident affected: XDR (XDR Service).