Incident Response: Degraded Reporting Latency

Incident Report for Barracuda Networks

Resolved

Reporting data is now all populated and available. We appreciate your patience as this issue was resolved and remdiated.
Posted Dec 08, 2025 - 19:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results. We expect that it will take a few days for the data to be available as the system recovers.
Posted Dec 02, 2025 - 20:37 UTC

Investigating

Incident Response is currently experiencing a delay in reporting and do not have data after November 28th. We are currently investigating and will update once the issue has been identified.
Posted Dec 01, 2025 - 19:28 UTC
This incident affected: Impersonation Protection (formerly Sentinel) (Dashboard UI).